Einrichtung von Email Postfächern Outlook 2016 (Autodiscover) benötigt lange oder hängt

Dieser Artikel beschreibt Lösungsmöglichkeiten für lange Wartezeiten (auch endlose Versuche) bei der Einrichtung von Mailkonten unter Outlook 2016 bei einem gehosteten Exchange System. Die Lösung trifft auf folgendes Setup zu:

  • Sie verwenden Hosted Exchange, Exchange Online oder Office 365 Exchange

  • Ihre Organisation nutzt ein Split-DNS Setup

    Ein Split-DNS Setup liegt dann vor, wenn die DNS-Zone der E-Mail Domain im internen Netzwerk von einem anderen DNS-Server verwaltet wird. Beispiel: Sie nutzen die Domain company.com für ein extern gehostetes Exchange und zugleich als Ihre Active Directory Domain.

Ursache

Outlook sucht auf mehreren Wegen nach der erforderlichen Konfiguration für den Zugriff auf Ihr Postfach. Die Reihenfolge wie auch die Verfahren haben sich von Version zu Version verändert. Bei Outllok 2016 beginnt dies wie folgt:

Outlook 2016 versucht zunächst die folgende Url unterhalb Ihrer Maildomain zu erreichen:

/autodiscover/autodiscover.xml

Wenn Sie z.B. max.test@company.com als Email- Adresse bzw. Benutzer eingegeben haben, versucht Outlook 2016 zunächst die folgdende Adresse zu erreichen:

https://company.com/autodiscover/autodiscover.xml

Bei einer gehosteten Lösung wird dies im Fall einer Split-DNS Konfiguration dazu führen, das Outlook versucht diese Adresse von einem Ihrer Domain Controller abzurufen. Da die Windows Firewall den Zugriff blockiert, kommt es nach einiger Zeit zu einem Timeout. Diesen Vorgang wiedeholt Outlook mehfach, was äußerst lange dauern kann.

Lösung

Durch den folgenden Eintrag in der Windows Registry, lässt sich dies abschalten:

Windows Registry Editor Version 5.00[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\AutoDiscover]
“ExcludeHttpsRootDomain”=dword:00000001

Weitere Informationen zu den möglichen Einstellungen für die Autodiscover Funktionalität finden Sie in dem verlinkten Microsoft Knowledgebase Artikel.